Archi Forum

Archi Plug-ins => coArchi => Topic started by: adam.h. on March 31, 2022, 07:53:47 AM

Title: GitHub: "Invalid remote: origin"
Post by: adam.h. on March 31, 2022, 07:53:47 AM
Hi,

We are keeping our models in GitHub. Access to the repo (refresh or update) started suddenly failing since a week with "Invalid remote: origin" error. It seems to be related to problem described here: Github.com RSA key with SHA-1 no longer allowed (https://www.eclipse.org/forums/index.php/t/1110330/)

Is there any quick fix/workaround in coArchi for this? Do you think you can release updated coArchi plugin anytime soon?

Thanks,
Adam
Title: Re: GitHub: "Invalid remote: origin"
Post by: Phil Beauvoir on March 31, 2022, 07:57:14 AM
Please generate a new SSH key as per these updated instructions:

https://github.com/archimatetool/archi-modelrepository-plugin/wiki/SSH-Authentication
Title: Re: GitHub: "Invalid remote: origin"
Post by: adam.h. on March 31, 2022, 08:17:13 AM
That helped, thank you.