Archi Forum

Discussion Boards => Archi Development => Topic started by: daveholliday on April 15, 2019, 15:08:02 PM

Title: Glib-CRITICAL errors when running Linux 64bit Archimate on Debian
Post by: daveholliday on April 15, 2019, 15:08:02 PM
Hello,

I am trying to run Archimate 64bit on Debian and am getting the following critical errors when i run it.

(Archi:3891): GLib-CRITICAL **: Source ID 1230 was not found when attempting to remove it

(Archi:3891): GLib-CRITICAL **: Source ID 1491 was not found when attempting to remove it

(Archi:3891): GLib-CRITICAL **: Source ID 1515 was not found when attempting to remove it

(Archi:3891): GLib-CRITICAL **: Source ID 1852 was not found when attempting to remove it

(Archi:3891): GLib-CRITICAL **: Source ID 2036 was not found when attempting to remove it

(Archi:3891): Gtk-CRITICAL **: gtk_distribute_natural_allocation: assertion 'extra_space >= 0' failed

(Archi:3891): Gtk-CRITICAL **: gtk_box_gadget_distribute: assertion 'size >= 0' failed in GtkScrollbar

Debian details:

PRETTY_NAME="Debian GNU/Linux 9 (stretch)"
NAME="Debian GNU/Linux"
VERSION_ID="9"
VERSION="9 (stretch)"

Output of uname -a = Linux penguin 4.19.16-02893-g2cf2c17c8a43 #1 SMP PREEMPT Sat Jan 19 09:52:07 PST 2019 x86_64 GNU/Linux

Any help much appreciated.

Title: Re: Glib-CRITICAL errors when running Linux 64bit Archimate on Debian
Post by: Phil Beauvoir on April 15, 2019, 15:13:07 PM
I've no idea what those messages mean. Does Archi actually run?

There could be any number of reasons for this - GTK version, Debian version. I can only suggest Googling this to see if any other apps have this error. If not, suggest a different Linux version, GTK, etc.

This might be connected https://bugs.eclipse.org/bugs/show_bug.cgi?id=538000
Title: Re: Glib-CRITICAL errors when running Linux 64bit Archimate on Debian
Post by: daveholliday on April 15, 2019, 15:27:58 PM
Hey,

Archi runs but i cannot select any of the tools in the main window after selecting a view, the palette of tools does not appear. I have attached a screenshot.

I will continue to hunt around the internet :)

Title: Re: Glib-CRITICAL errors when running Linux 64bit Archimate on Debian
Post by: Phil Beauvoir on April 15, 2019, 15:29:52 PM
Could be the GTK version.

See https://github.com/archimatetool/archi/issues/462

And

export SWT_GTK3=0