Script error

Started by Alberto, November 11, 2021, 21:15:04 PM

Previous topic - Next topic

Alberto

I've been using the MergeTwoElements.ajs script but I think since I upgraded to 4.9.1 and started using specialization, I've been getting the following error:

Script Error: java.lang.NoClassDefFoundError: com/archimatetool/editor/preferences/Preferences

What am I missing?

Phil Beauvoir

Are you using jArchi 1.2? This version is required for Archi 4.9.x
If you value and use Archi please consider making a donation! https://www.archimatetool.com/donate

Alberto


gmamvura

Hello I upgraded Archi to 4.9.3 and when I attempt to use my old com.archimatetool.script_1.1.0.202101121529.archiplugin I get this message : Script Error: java.lang.NoClassDefFoundError: com/archimatetool/editor/preferences/Preferences

Jean-Baptiste Sarrodie

Hi,

Quote from: gmamvura on March 22, 2022, 20:36:58 PMHello I upgraded Archi to 4.9.3 and when I attempt to use my old com.archimatetool.script_1.1.0.202101121529.archiplugin I get this message : Script Error: java.lang.NoClassDefFoundError: com/archimatetool/editor/preferences/Preferences

As Phil wrote, jArchi 1.2 is the minimum version needed for Archi 4.9.x.

Regards,

JB
If you value and use Archi please consider making a donation! https://www.archimatetool.com/donate