Content of views gets lined up

Started by hvn52, November 18, 2021, 11:37:50 AM

Previous topic - Next topic

hvn52

Hi,

Using Archi 4.8.1, I created a test model with views for Business, Application, Technology and Motivation. I saved them, closed all views and Archi. Then opened Archi and opened all views. Then I was surprised that the results were not as how I saved them. As an example, see the attachments.
I just downloaded & installed 4.9.1, but that made no difference.
The *wish-version is how I saved it and how I wished it would open, the other is how it did open. Did I do something wrong, or should I have done something that I didn't do when opening again?

Thanks

Phil Beauvoir

That sounds strange. Can you provide steps to reproduce this?
If you value and use Archi please consider making a donation! https://www.archimatetool.com/donate

hvn52

All steps:
1 close the Motivation view
2 select Motivation
3 select all elements in Motivation
4 right-click, select Generate View for ... and select e.g. Stakeholder
5 click OK

And all element positions are lined up vertically again. Considering your reaction, this isn't what is supposed to happen.

Phil Beauvoir

"Generate View for..." creates a new View with a default layout from selected elements. You then have to arrange the elements of the new View. Sounds like it's working as expected, but you are perhaps misunderstanding something?
If you value and use Archi please consider making a donation! https://www.archimatetool.com/donate

hvn52

November 18, 2021, 12:20:22 PM #4 Last Edit: November 18, 2021, 12:33:08 PM by hvn52
Quote from: Phil Beauvoir on November 18, 2021, 12:13:37 PM"Generate View for..." creates a new View with a default layout from selected elements. You then have to arrange the elements of the new View. Sounds like it's working as expected, but you are perhaps misunderstanding something?

Sounds like I do misunderstand something, but need to find out what.

Edit: ok, so a view is generated from whatever element and viewpoint you select. But how do I get a view of all elements from (in this case) Motivation that has no specific generated viewpoint but shows the elements as I pictured them?

Jean-Baptiste Sarrodie

Hi,

Quote from: hvn52 on November 18, 2021, 11:37:50 AM[...]
I saved them, closed all views and Archi. Then opened Archi and opened all views. Then I was surprised that the results were not as how I saved them.
[...]

There's only one single explanation: it didn't get saved, or you saved it as another file and opened the previous one.

A view generated by "Generate View for..." action has nothing special: it is created and then you manually edit it, so if you did it and saved it, you find it again when you reopen your model.

Regards,

JB
If you value and use Archi please consider making a donation! https://www.archimatetool.com/donate

Phil Beauvoir

Quote from: hvn52 on November 18, 2021, 12:20:22 PMEdit: ok, so a view is generated from whatever element and viewpoint you select. But how do I get a view of all elements from (in this case) Motivation that has no specific generated viewpoint but shows the elements as I pictured them?

The "Generate View For..." function is not intended to be the default way to create a View and add concepts to that View. The workflow is to create blank Views (right-click on the "Views" folder, New -> ArchiMate View) and then add elements to the Model Tree and drag and drop them to the View and/or drag and drop concepts from the Palette.
If you value and use Archi please consider making a donation! https://www.archimatetool.com/donate