[Solved] Copy view as image to clipboard not working in Linux 64bit

Started by ErikR, November 26, 2016, 06:23:10 AM

Previous topic - Next topic



I am using Archi a lot and are in general very happy with it. I am using it at work in a windows 7 environment and at home in a Linux environment. Problem is that in my Linux environment the Ctrl-Shift-C does not trigger Copy View as Image to Clipboard. This is quite important when using the views in a document. I cannot find this option in the menu either.

I have verified that the colliding global short-cut is disabled and logged out and in again after that. It was connected to KWin (I run KDE 5).

I assume that this is not due to broken Archi but rather some dependency I might have missed. I am running Archi 3.3.2 and used the .tar-file for the installation. I assume there is a dependency that I might lacking. I do get an error message that the Canberra module faled to load but that is about sound events.

Export to image on file works well though but is very cumbersome when using the views in a document. 

Any hints what I should look for?


Jean-Baptiste Sarrodie


The option to copy the view as image in the clipboard has been removed from linux version some years ago, because of some Eclipse framework bugs under this OS.

@Phil: we might re-try it now that Archi 4 is based on Eclipse Neon...


If you value and use Archi, please consider making a donation!
Ask your ArchiMate related questions to the ArchiMate Community's Discussion Board.

Phil Beauvoir


J-B is correct. I did put this in the manual:

"Export View As Image to Clipboard
Note - this is not implemented on the 64-bit Linux version of Archi due to a bug in Eclipse."

The problem is caused by a bug in Eclipse on 64-bit Linux:


(You will find my comment in that bug report, where you can see I'm not too happy!)
If you value and use Archi please consider making a donation. :-)



I was not aware of this and naturally I am running 64 bit Linux  :P



So this is how I solved it.

I downloaded 32 bit jre from Oracel as tar.gz and unpacked somewhere (/usr/local/jre32/jre1.8.0_111).
I set some variables:
export JAVA_HOME=/usr/local/jre32/jre1.8.0_111/
export PATH="${JAVA_HOME}/bin:${PATH}"

And I start Arch32 instead of Arch64.

Viola, copy to clipboard works :) And I can get busy again  ;D
By the way, I am running funtoo 64 bit with multilib set. All libraries I install will be in both 32 and 64 bit. This is likely a must for this solution to work.

Thanks for the pointer in relevant direction!



Well, I was a bit optimistic here ;)
Archi starts al-right but copy and past into LibreOffice does not work. I need to middle-paste into a pain program to get it work.

Perhaps this is the bug mentioned. Still, copy via paint-program is easier than save to file, add file so we'll see.

// Erik