Archi Collaboration Plugin - Saved to local file and now can't relink to GIT

Started by David Molesworth, June 21, 2018, 22:01:40 PM

Previous topic - Next topic

David Molesworth

Hi there

I was working on a shared GIT repo, but needed to share the model with a client, so I did a "save as" (.archimate file).  Continued to work on the model and eventually at the end of the day went to save back up to the GIT repo, but now all of the collaboration options are disabled.  The "save as" unlinked the model from GIT repo?  Only option in list is to "Add Local Model to Workspace and Publish", but when I provide credentials, it complains model already exists in GIT repo.

Any suggestions how I merge the local copy with the one in GIT repo?  Open both models at the same time and somehow do a merge?

Thanks for your help in advance.


Phil Beauvoir

David, the original git-based model should still exist in the Collaboration Workspace tab. You should regard the one you did a "Save As" on as a separate model and try to copy and paste or manually add to the git-based one.

Note - this is the kind of thing the upcoming jArchi scripting language should help with - merge two models. In the meantime, I'm afraid you'll have to do it manually, unless someone else has a better idea.
If you value and use Archi please consider making a donation. :-)

Jean-Baptiste Sarrodie


I can think of another option (kind of hack): you can save back your copy over the temp.archimate file which sits insite the .git folder of the local copy of the model (path can be found through the property tab when you clic on the model in collaboration workspace) . You'll then be able to commit and merge your changes.


If you value and use Archi, please consider making a donation!
Ask your ArchiMate related questions to the ArchiMate Community's Discussion Board.

David Molesworth


I followed your advice.  I saved my off-line model and closed down Archi.  I took a copy of the associated off-line .archimate file and copied that to my local GIT repository that was originally linked to the central GIT repository ie. C:\Users\<userID>\AppData\Roaming\Archi4\model-repository\<modelName>\.git.  There was no temp.archimate file in there, just a temp.archimate.bak and temp.archimate.old.  I assume they got created when I disconnected my local repo doing the 'save as'.

I renamed my off-line .archimate file copy in C:\Users\<userID>\AppData\Roaming\Archi4\model-repository\<modelName>\.git to temp.archimate.  Double clicked on the temp.archimate file to open Archi.  Then did a "commit change", and then a "publish changes".  It's all seems sorted now.

Thanks a lot for your help.