specialization plugin with Archi 4.3.3 / Mac Mohave 10.14.4

Started by newbie1234, April 01, 2019, 14:43:46 PM

Previous topic - Next topic

newbie1234

Hi Herve'

Today I updated Archi on my mac laptop (Mohave 10.14.4) to version 4.3.3 and re-installed your database and specialization plugins that I had been using on Archi 4.3.1 last week just fine.  I also re-installed the collaboration plugin that I had been using.

With the newest Archi version, the icons are not appearing in the models.  The database plugin seems to work fine as does the collaboration plugin as both pull in the models, just the icon replacements do not seem to be working for me.

I initially tried the newest specialization plugin version "org.archicontribs.specialization_v1.0.11.jar", that worked last week with Archi 4.3.1, then backed down to version "org.archicontribs.specialization_v1.0.10.jar" residing in the plugins folder of Archi.  Both have the same behavior on my laptop.  The preferences panel contents seem good for pointing at the icon folder on my laptop.

Please let me know if you can see the same behavior as I am.  I will certainly capture any information that I can from my laptop that may help, and forward to figure out what is happening for me in my installation.

Many thanks again for your patience, and hard work on supporting these plugins!

Hervé

Good evening,

Thanks to Phil and JB, I changed the procedure to generate the JAR files and per my knowledge, they now work on MAC.

Unfortunately, MAC seems to require that the JAR file has got the very same name as it has been generated (which is not the case for Windows and Linux). At the beginning of my dev, I unfortunately put a "v" in the filename, and I have to stick with this to accommodate the automatic update procedure (that I need to rewrite at some stage).

That's the reason why I created a "test for MAC" folder with the JAR file that has not been renamed and I just test it, it works well with Archi 4.3.3 on MAC.

As you already downloaded the JAR file, please just rename it from "org.archicontribs.specialization_v1.0.11.jar" to "org.archicontribs.specialization_1.0.11.jar" (without the "v") and the plugin should behave correctly.

Best regards
Hervé

Hervé

By the way, please be informed that I started to develop the v2 of the plugin that will include the following changes:

  • Fix the JAR file renaming (for MAC users)
  • The plugin will not require local folders anymore, but use icons/pictures from the model (this will allow to transmit the icons/images in the model)
  • Stick more to the Archimate notion of specialization

         
    • It will possible to associate an icon/image and a list of properties to a specialization
    • It will be possible to specialize concepts, this will automatically associate the corresponding icon/image and create the corresponding properties

Best regards
Hervé

newbie1234

Hi Herve'

Wow, persnickety macs.... 

Renaming the file did the trick. 

Many thanks again for everyone's help!!