Error when using Import Model to Workspace

Started by jyves, August 29, 2019, 09:21:32 AM

Previous topic - Next topic


When using "Import Remote Model to WorkSpace" I get the following error "There was an error: Connection timed-out: connect".
I have checked successfully the URL and the credentials with my Navigator (IE 11), the access is ok.
In the Collaboration preferences I did not specify any proxy to align with the Internet configuration of my Navigator.
The LAN settings of my Navigator is "Automatically detect settings" is selected, no proxy server is selected.
I made several verifications and Archi is not blocked by my Windows Defender Firewall.
I use Archi version 4.4.0.
Any idea to investigate this problem ?

Phil Beauvoir

Hi, it's hard to diagnose this kind of problem without a lot more information regarding network setups, git host and so on. Can you provide any more details?
If you value and use Archi, please consider making a donation!
Ask your ArchiMate related questions to the ArchiMate Community's Discussion Board.


Please find attach the Archi Collaboration Preferences and the LAN parameters setting.
Could you precise the other settings that could be useful ?

Phil Beauvoir

What is the git server? Is it something like GitHub, GitLab or network server? Do you have to have special credentials? What is the URL type of the git server.

Also, search here in case someone had a similar problem -
If you value and use Archi, please consider making a donation!
Ask your ArchiMate related questions to the ArchiMate Community's Discussion Board.


The Git server is a network server, the URL is
I can access this URL with my IE navigator using same credentials I use when importing the remote model to workspace.
Attach is the Windows Defender configuration.


Hi Jyves,

I had similar issue when first setting up for my client on their network - you can try the following to see if you get further:

1. To test install GIT for Windows and try to clone your remote GIT repo - if this succeeds then all good so far
2. If you are using in a work organisation then there surely must be a proxy that you will need to get through - you need to confirm and setup details in the collaboration settings.
3. If step 1 succeeds and step 2 is confirmed then I suspect that endpoint is unreachable due to SSL certificate issue.  I found that the SSL being stored in the Windows Certificate Manager (Trust Store) is being accessed correctly by GIT for Windows, but not so for Archi.  Try adding the following parameters to the Archi.ini file, which instructs it to use the WCM - this worked for me after a lot of research and trial & error.

Hope this helps.


Hi Manj75,

Thanks for your help.
1) I successfully installed GIT and tried to clone my remote GIT repo.
I got an error very similar to the one I get with Archi, that is : 
"fatal: unable to access 'ttps://': Failed to connect to port 443: Timed out.
2) I tried also to add and in my Archi.ini file. I got the same error in Archi (connection time-out).

Any other idea ?


Hi jyves,

Sorry for the late reply.

Seems to me that there is an underlying issue with access to the endpoint and likely to do with SSL certificates.  The fact that a separate GIT application is getting the same error means that you don't have the correct certs installed.

Kind Regards,