Author Topic: Does anyone else get a leading "=" on auto-generated ID's during .CSV export?  (Read 687 times)

KenGarvey

  • Newbie
  • *
  • Posts: 3
I've seen some old posts about the CSV export/import functionality but nothing recently.

The circumstances are that I'm building up a current state model by importing elements from CSV. 
On import the new elements get allocated a unique ID by Archi. 
When I save that model to CSV and try to import from CSV I get errors. 
On investigation between 5% and 10% of the newly generated ID's have an extra field before the "ID" containing "=". 

This field exists but doesn't show when I open the CSV in a spreadsheet but is fairly easy to spot in a text editor.  I have a workaround where I locate the element or relationship affected in the model, duplicate it, delete the original and export > csv > import to check it's clean.
This usually takes one or two passes to get all of them but the effort increases with the amount of data and as I add relationships that is growing exponentially (I'm building out the technology layer and adding system software elements to nodes).

Anyway I wanted to ask if it's something others have seen and if anyone has a neater workaround or fix before I raise it as a potential bug?

Phil Beauvoir

  • Administrator
  • Hero Member
  • *****
  • Posts: 1639
  • Code Punk
    • Archi
Sounds like you have the "Use Excel leading zeros/spaces workaround" option checked when exporting to CSV. This places a "=" in front of the ID if it starts with a zero (See the Archi User Guide, page 82.) A quick Google of this will explain it better.
If you value and use Archi please consider making a donation! https://www.archimatetool.com/donate

KenGarvey

  • Newbie
  • *
  • Posts: 3
Thanks Phil, yes I left that checked as per default. 
So this option is only when you wish to view the CSV export in Excel and it prevents the exported CSV being imported again to Archi? 
I'd missed that. I will uncheck in future.

Phil Beauvoir

  • Administrator
  • Hero Member
  • *****
  • Posts: 1639
  • Code Punk
    • Archi
Yes, that's right.

But really one shouldn't just open a CSV file in Excel, as it makes assumptions about the data that might not be correct. One should really import it in Excel from Excel's Data -> From Text option.
If you value and use Archi please consider making a donation! https://www.archimatetool.com/donate

Jean-Baptiste Sarrodie

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 729
  • Archi Evangelist and Contributor. Visionary.
    • About me...
Hi,

So this option is only when you wish to view the CSV export in Excel and it prevents the exported CSV being imported again to Archi? 

This option is to support the following use-case: exporting a model, editing it in Excel, and importing back into Archi. In such case, you want to make sure the file can be opened in Excel without any missing or changed information. When saving the CSV from Excel, this additional markup will be removed and the resulting files can be imported in Archi.

Regards,

JB
If you value and use Archi please consider making a donation! https://www.archimatetool.com/donate