Error after importing relationships

Started by manonvanrooijen, May 18, 2021, 09:59:15 AM

Previous topic - Next topic

manonvanrooijen

After I've imported my relationships.csv I get the following error
"Diagram connection has orphaned ArchiMate relation" (capture.png)

How can I fix this?
As far as I know all elements are connected.
Also see attached relations.csv

Phil Beauvoir

May 18, 2021, 10:08:07 AM #1 Last Edit: May 18, 2021, 10:16:26 AM by Phil Beauvoir
Is this error only happening after you have imported the CSV fie?

Is the model OK before you do this?

Are you using any other Archi plug-ins? (coArchi, jArchi, or other?)

Can you explain more what you are trying to do? Where do these relationships come from? We really need more information to figure out what's going on here.
If you value and use Archi please consider making a donation! https://www.archimatetool.com/donate

manonvanrooijen

Hi Phil, thank you for your time!

The error occurs only after I've imported the relationships.

Here is my sequence:
I Import new elements. trough elements.csv
Save my Model
Close the Model
Close Archi
Reopen the Model
Export the model to csv

Open the elements.csv in Notepad
Select the ID's of the newly imported DataObject elements and the "Source"  element they should connect to
Open the relations.csv in Notepad
Add the relationships between the Source and Target elements
Save.
In the model, select import from CSV
The relationships get imported no problem.

I then Drag both the source and target elements in a new view.
I select all target elements and drag them in the source element.
The assigned relationship appears in the view.

However, when selecting one of the elements in my view, the relationship remains italic and I cannot save the model, the afore mentioned error occurs.

I am working in Archi 4.8.0 Build: 202012140831
I have the following plugins installed (see Capture2.png)



Phil Beauvoir

May 18, 2021, 11:37:52 AM #3 Last Edit: May 18, 2021, 15:05:18 PM by Phil Beauvoir
One thing that could present problems is having the "elements.csv" file alongside the modified "relations.csv" file when importing.

When Archi imports the CSV files it looks for matching "elements", "relations" and "properties" files as a set of files to import. So if they are present they are all imported even if you only select one of them in the file selection dialog.

You could try either removing the other file(s) or moving the "relations.csv" file somewhere else before importing it.

If that doesn't work then maybe you could provide a reproducible test case (example model and csv files).
If you value and use Archi please consider making a donation! https://www.archimatetool.com/donate

manonvanrooijen

That did the trick.
Thanks! Saves me loads of work :D