Could not get credentials file

Started by ElFuegoGrande, November 30, 2021, 10:05:58 AM

Previous topic - Next topic

ElFuegoGrande

Hi

I have two users of Archi - Windows 10 - Archi 4.9.1.  coArchi Version 0.8.0.

When they attempt to Import Remote Workspace to Model they get the following error.

There was an error
ssh://git@ourgitlabrepository:
Could not get credentials file!

I've checked their ssh_config files - and they have their Identity file is there - and I've checked the Collaboration Tool preferences setting via the UI in Archi - and it is pointing at the correct file.  They both have multiple identity files.

We also had the same issue with  Mac user.

Bit stumped on this one - did search the forum and found one slightyl similar issue but without a clear resolution.

Any suggestions or advice would be most helpful

Many thanks

Phil Beauvoir

SSH can be problematic if the credentials file is not in the correct format.

See:

https://github.com/archimatetool/archi-modelrepository-plugin/wiki/SSH-Authentication

Other than that, it's hard to diagnose. Could you use HTTPS?
If you value and use Archi please consider making a donation! https://www.archimatetool.com/donate

ElFuegoGrande

Thanks Phil

No - we're stuck with SSH - we don't use https for git lab.

It's frustrating and to be honest I suspect user error during setup may be an issue - although it is odd it's two people - getting the same error - so if so they have both managed to independently arrive at the same failed state!  Can you suggest any logs I could investigate to try and narrow down the source of the problem?  As is usual with these things it all works fine for me!  And I've not been able to replicate the issue!

Phil Beauvoir

November 30, 2021, 12:49:40 PM #3 Last Edit: November 30, 2021, 18:56:21 PM by Phil Beauvoir
I checked the code and the error "Could not get credentials file!" is raised if the credentials file ("secure_ssh_credentials") does not exist. This file stores the password to the ssh identity file. The password for the SSH identity file is set in Preferences. Can you double check this?
If you value and use Archi please consider making a donation! https://www.archimatetool.com/donate

ElFuegoGrande

Thanks Phil - that's very helpful.

I can't find "secure_ssh_credentials" on my machine - but the collaboration plugin works for me so it must be somewhere.

I've tried C:\Users\myusername\AppData\Roaming\Archi4\

And it's sub directories - I've also searched my entire directory structure - so I suspect it's either in a hidden directory - or packaged away and not revealed until the collaboration addin needs it.

Is it written to a standard location?

Phil Beauvoir

It's in C:\Users\myusername\AppData\Roaming\Archi4\model-repository

It's a small file that contains the encrypted SSH password for the SSH file.

But the important thing is that the password should be set in Collaboration Preferences under "Identity Password".
If you value and use Archi please consider making a donation! https://www.archimatetool.com/donate