Compatability

Started by pquodling, November 27, 2015, 22:24:17 PM

Previous topic - Next topic

pquodling

In the interests of having more working models, and better understanding Archi, I thought, I would look for examples. I found reference to the archinsurance example, but also the "Archimetal" example and located it at https://github.com/archimatetool/ArchiModels/tree/master/ArchiMetal

Trying to load it, I get the message "Cannot open '/Users/peter/Desktop/Archimetal.archimate'. This model is incompatible. Package with url "null" not found. (file /Users/peter/Desktop/Archimetal.archimate,6,59)

The Git repository says that it worked with 2.1

So? where does one find the differences between versions that would make this imcompatible?

Phil Beauvoir

November 27, 2015, 23:16:55 PM #1 Last Edit: November 27, 2015, 23:18:38 PM by Phil Beauvoir
Hi,

how did you download it? It's part of a git repository so you can't do a "save link as" from the browser.

If you're using a browser try saving this https://raw.githubusercontent.com/archimatetool/ArchiModels/master/ArchiMetal/ArchiMetal.archimate

Phil
If you value and use Archi please consider making a donation! https://www.archimatetool.com/donate

prgee

Hi,

You could also get it by downloading the official ArchiMetal model as an ArchiMate Model Exchange File from The Open Group at

https://www2.opengroup.org/ogsys/catalog/Y140

You will find a PDF containing the case study document as well. You may have to register with the Open Group to do this but you can register as an individual member for free anyway. Besides, they have some great supporting material on ArchiMate modeling.

Cheers,
Peter

Phil Beauvoir

And you can also download it in ArchiMate Model Exchange File format in the git repo:

https://raw.githubusercontent.com/archimatetool/ArchiModels/master/ArchiMetal/OG%20Exchange%20Format/ArchiMetal.xml
If you value and use Archi please consider making a donation! https://www.archimatetool.com/donate

halex

Hi.
I'm getting the same problem ... "this model is incompatible" since I'm a newbie ... maybe I'm doing something wrong ..
Thanks,
Helder

Phil Beauvoir

December 04, 2017, 16:06:13 PM #5 Last Edit: December 04, 2017, 16:08:51 PM by Phil Beauvoir
Quote from: halex on December 04, 2017, 16:04:05 PM
Hi.
I'm getting the same problem ... "this model is incompatible" since I'm a newbie ... maybe I'm doing something wrong ..
Thanks,
Helder

Helder, please detail the exact steps that you are doing to get this error.

Edit - if you are trying to import the exchange file, it won't work because it hasn't been updated to version 3.0 of ArchiMate.

Phil
If you value and use Archi please consider making a donation! https://www.archimatetool.com/donate

halex

Hi Phil,
I downloaded a package (zip file) "ArchiMate® Model Exchange File Format for the ArchiMate Modeling Language, Version 3.0" from opengroup and I was able to import the archisurance model -ArchiSurance V3.xml. Previously I was trying to import a different version ... an archimate extension file.
Sorry for the late answer.
Thank you for all your support.
Thanks,
Helder Alexandre