Set as Target Platform

Started by sahar, May 13, 2017, 07:29:31 AM

Previous topic - Next topic

sahar

Hello
In Running and Debugging Archi where need to set target platform, I got this error:
http://download.eclipse.org/eclipse/updates/4.6
"Unable to locate installable unit org.eclipse.emf.sdk.feature.group"

My eclipse version is 4.4.2 and I change the version number in URL from 4.6 to 4.2, but still doesn't work.

Phil Beauvoir

It should work, even though you are using an earlier version of Eclipse. Try using Eclipse SDK 4.6 as the host. Or it may simply be a connection error.
If you value and use Archi please consider making a donation! https://www.archimatetool.com/donate

sahar

I add this URL  http://download.eclipse.org/eclipse/updates/4.6 in "Install new software" but I can't found installable unit org.eclipse.emf.sdk.feature.group.

Is this ok and not related to my issue??

Phil Beauvoir

#3
You should start with Eclipse 4.6 as host then you don't need to do that. The target platform is unrelated to the host platform.

Download from http://download.eclipse.org/eclipse/downloads/drops4/R-4.6.3-201703010400/

If you value and use Archi please consider making a donation! https://www.archimatetool.com/donate

sahar

Thanks, I passed this step, in the next step when select "Launch an Eclipse Application in Debug mode" these errors appear:

!ENTRY org.eclipse.help.ui 4 0 2017-05-13 14:35:55.682
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.help.ui [77]
  Unresolved requirement: Require-Bundle: org.eclipse.ui.forms; bundle-version="[3.5.0,4.0.0)"

   at org.eclipse.osgi.container.Module.start(Module.java:444)
   at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1620)
   at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1599)
   at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1571)
   at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1514)
   at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
   at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
   at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.equinox.app 0 0 2017-05-13 14:35:56.213
!MESSAGE Product com.archimatetool.editor.product could not be found.

!ENTRY org.eclipse.help.ui 2 0 2017-05-13 14:35:56.307
!MESSAGE Could not resolve module: org.eclipse.help.ui [77]
  Unresolved requirement: Require-Bundle: org.eclipse.ui.forms; bundle-version="[3.5.0,4.0.0)"


!ENTRY org.eclipse.osgi 4 0 2017-05-13 14:35:56.307
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
   at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:242)
   at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
   at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
   at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
   at java.lang.reflect.Method.invoke(Unknown Source)
   at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
   at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
   at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
   at org.eclipse.equinox.launcher.Main.main(Main.java:1492)

Phil Beauvoir

Did you click the "Set as Target Platform" in archi.target?
If you value and use Archi please consider making a donation! https://www.archimatetool.com/donate

sahar

Yes, and wait for download all the required plug-ins.

sahar

Ok, my problem is solved (all plug-in downloaded successfully)
Project "com.archimatetool.importexportexample" have a red cross, in class MyExporter.java "import com.archimatetool.model.IArchimateComponent" cannot be resolved, how can i solve this?

Phil Beauvoir

#8
I just updated and fixed that project. You need to do another "pull" from Git. Or you could simply close the project.
If you value and use Archi please consider making a donation! https://www.archimatetool.com/donate

sahar