Archi - Git connection issue

Started by viraght, December 01, 2017, 15:26:03 PM

Previous topic - Next topic

viraght

I want to use Archi with GitHub as an architecture repository. I planned to use the plug-in to Archi that allows collaborative work on Archi through sharing and versioning of models in a Repository.
I am an absolute beginner regarding Git, Github, Personal Access Token and things like that.
I tried to follow suggestions from our IT colleagues. They know the on-premise instance of GitHub residing within the DXC company network where I am working. But they do not know Archi and the Archi plug-in.
I attached a detailed description. Could somebody help me to connect to GitHub?
Thanks, Tamas

Phil Beauvoir

December 01, 2017, 16:15:30 PM #1 Last Edit: December 01, 2017, 16:20:03 PM by Phil Beauvoir
If you using GitHub, you should create a new repository for each model that you want to share and use https. For example:

https://github.com/archimate-models/archisurance.git

And then you can push your model to that repository.

Also - a password is needed, not a token.
If you value and use Archi please consider making a donation! https://www.archimatetool.com/donate

viraght

The plugin works well with github.com. I have problems only with the on premise instance of GitHub Enterprise inside the corporate firewall. First I had to define the company proxy in Archi / Edit / Preferences / Collaboration. It was simple. But I am not sure what user name and password I have to provide when I want to add my local Archi model to Workplace and Publish. The user authentication is somehow difficult in the company. When I am accessing that on premise GitHub Enterprise server from a web browser I am redirected to a company page for authentication and from that page I go forward to an older company page to type in my email address and password there. Finally I found myself on GitHub page. A colleague suggested me to create Personal Access Token with GitHub Enterprise and use that long hexadecimal string instead of a password in the Archi plugin window. I am not sure weather this can work with my email address as user name in the Archi plugin dialogue? Any suggestions?   

Phil Beauvoir

Archi makes a direct connection using HTTPS to the Git repository. So therefore only a username and password will work. Are you using HTTPS?
If you value and use Archi please consider making a donation! https://www.archimatetool.com/donate

viraght

Thanks Phil Beauvoir for your answer. Yes, I am using HTTPS. The details: I visited our on premise GitHub Enterprise server now from Chrome Browser. I was connected to my company intranet network and I provided the URL (like https://github.mycompany.net/) The new HTML page in the browser contained the message: "You are not signed in. Sign in with SAML to access your account." When I clicked the "Sign in with SAML" link here a new dialog box opened containing the list of my digital certificates. I selected the certificated provided by my company to authenticate myself. Dialog closed and I found myself in GitHub opening page signed in as tamas-viragh. So based in this experience I am not sure what I have to type in as User Name and as Password in the dialog box of the Archi plugin? For user name the logical possibilities are (1) my GitHub user name: tamas-viragh or (2) my company email address tamas.viragh@mycompany.com. For the Password field I have no idea: (1) My company password I normally use to access Windows domain resources or (2) the long hexadecimal string I received when I generated a Personal Access Token at https://github.mycompany.net/settings/tokens. The possibilities mentioned above seems not to work for me. What can I do to access this on premise GitHub from Archi plugin? Just an additional question: the plugin works well with "GitHub Enterprise" as well as with "GitHub" (I do not know the differences just realized the name is GitHub Enterprise)?   

Phil Beauvoir

A suggestion - you could download a free Git client (like smartgit) and connect to your repo using this. Then see what settings you use to connect.
If you value and use Archi please consider making a donation! https://www.archimatetool.com/donate

viraght

Thanks for your suggestion Phil Beauvoir. I downloaded and installed Smartgit on my Windows10 machine. I added my local repository. A new window popped up when I wanted to commit: Windows Security - Git Credential Manager for Windows
Enter your credentials for https://github.mycompany.net/.
I typed in my email address as User name and my Windows domain password as Password.
The error message I received:
Unable to access 'https://github.mycompany.net/tamas-viragh/MNB_Kondor-kozeli.git/': The requested URL returned error: 403
remote: Password authentication is not available for Git operations.
remote: You must use a personal access token or SSH key.
remote: See https://github.mycompany.net/settings/tokens or https://github.mycompany.net/settings/ssh
unable to access 'https://github.mycompany.net/tamas-viragh/MNB_Kondor-kozeli.git/': The requested URL returned error: 403
My comment: Earlier I created a personal access token on this Github Enterprise. I received a long hexadecimal string there. Can that be used somehow with Archi plugin? Or is there any other way to access the GitHub server from the Archi plugin?

Phil Beauvoir

Did you get Smartgit to connect? If so, what settings?
If you value and use Archi please consider making a donation! https://www.archimatetool.com/donate

Jean-Baptiste Sarrodie

Hi,

I had to help a colleague today in a similar context (GitHub Enterprise). In fact this is really easy:

1/ You have to create a personnal access token (PAT) with the right level of access right (at least read/write on your repos). You've done this before.
2/ Use this PAT as the password when Archi asks you to authenticate. The trick here is that your username is your GitHub username which is not necessarily the same as the Id you use to authenticate yourself to your enterprise portal/SSO/SAML provider. This GitHub username never contains '@' and is visible on your "profile" page and also on the URL of your own repos. It usually is your enterprise ID without the @domain part.

Regards,

JB
If you value and use Archi please consider making a donation! https://www.archimatetool.com/donate

viraght

Hi Jean-Baptiste Sarrodie,
thanks for the detailed instructions. This worked for me!
Now I can try to utilize the possibilities of the integration with GitHub. This seems to me very useful to start teamwork in Archi.
Regards,
Tamas