Author Topic: Archi 4.8.1 Ubuntu 16.04 Unable to move elements and crash  (Read 773 times)

quonn77

  • Newbie
  • *
  • Posts: 2
Archi 4.8.1 Ubuntu 16.04 Unable to move elements and crash
« on: March 22, 2021, 11:15:02 AM »
Hello to everyone,
I am quite new to Archimate language and to Archi tool, I have downloaded latest version from the site, I have correctly unpacked and started the application but I am experiencing some unexpected behavior: When I add any element to any view I cannot move it from the default position . If I try to move an element from the model tree to the View Area I got the software crashing with error like:
".archi4/.config/org.eclipse.osgi/161/0/.cp/libswt-pi3-gtk-4940r23.so: undefined symbol: gdk_device_get_seat"

Do you have any advice?

Phil Beauvoir

  • Administrator
  • Hero Member
  • *****
  • Posts: 1639
  • Code Punk
    • Archi
Re: Archi 4.8.1 Ubuntu 16.04 Unable to move elements and crash
« Reply #1 on: March 22, 2021, 11:20:09 AM »
Archi 4.8.1 is not supported on Ubuntu 16.0.4. Please use later versions, preferably 20.x

See also https://forum.archimatetool.com/index.php?topic=949.msg5172#msg5172
If you value and use Archi please consider making a donation! https://www.archimatetool.com/donate

quonn77

  • Newbie
  • *
  • Posts: 2
Re: Archi 4.8.1 Ubuntu 16.04 Unable to move elements and crash
« Reply #2 on: March 23, 2021, 14:16:41 PM »
Thank you I have missed it. Do you plan to have a docker image of the Archi tool?

Phil Beauvoir

  • Administrator
  • Hero Member
  • *****
  • Posts: 1639
  • Code Punk
    • Archi
Re: Archi 4.8.1 Ubuntu 16.04 Unable to move elements and crash
« Reply #3 on: March 23, 2021, 14:20:48 PM »
Thank you I have missed it. Do you plan to have a docker image of the Archi tool?

No plans for that. This is something a user should create to their own requirements.
« Last Edit: March 23, 2021, 14:36:47 PM by Phil Beauvoir »
If you value and use Archi please consider making a donation! https://www.archimatetool.com/donate

Jean-Baptiste Sarrodie

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 729
  • Archi Evangelist and Contributor. Visionary.
    • About me...
Re: Archi 4.8.1 Ubuntu 16.04 Unable to move elements and crash
« Reply #4 on: March 23, 2021, 16:07:53 PM »
Hi,

Thank you I have missed it. Do you plan to have a docker image of the Archi tool?

Do a simple query on hub.docker.com and you'll see that many peple already created such image: https://hub.docker.com/search?q=Archimate&type=image

Regards,

JB
If you value and use Archi please consider making a donation! https://www.archimatetool.com/donate

tsanov

  • Newbie
  • *
  • Posts: 4
Re: Archi 4.8.1 Ubuntu 16.04 Unable to move elements and crash
« Reply #5 on: April 03, 2021, 19:06:32 PM »
Hey there,

Thank you I have missed it. Do you plan to have a docker image of the Archi tool?

I am using Archi 100% under Docker, currently on Ubuntu 20.04, here's my Dockerfile and the bash script I'm launching it through: https://github.com/tsanov/dockerfiles/tree/master/archi . Please note that I am still rocking version 4.6.

Should you hit a snag, don't hesitate to reachout (big fan of Docker here).

Nik

egar4mimil

  • Newbie
  • *
  • Posts: 1
Re: Archi 4.8.1 Ubuntu 16.04 Unable to move elements and crash
« Reply #6 on: April 13, 2021, 10:06:03 AM »
Hi,

I want to create a docker image of archi 4.8.1 but I need a permanent link to the image.

Do you have this ?

tsanov

  • Newbie
  • *
  • Posts: 4
Re: Archi 4.8.1 Ubuntu 16.04 Unable to move elements and crash
« Reply #7 on: April 17, 2021, 14:29:22 PM »
Hi egar4mimil,

Could you please specify how exactly do you plan using this docker image? For example, I use mine instead of desktop installation, for housekeeping purposes, so that I don't clog my system with Java RE and such. However, this comes at a prise - X-forwarding, directories mapping, etc. I am using Archi under docker on macOS and Linux (Ubuntu 20.04 currently).

So if you specify your situation (what you'd like to do and under what operating system) I can try upgrading my Dockerfile (link to the GitHub repo posted above) to 4.8.1 so that you can build it locally and use it (I strongly encourage you to always rebuild unverified publishers' images with
Code: [Select]
docker build . -t whatever).

Thanks,
Nik
Hi,

I want to create a docker image of archi 4.8.1 but I need a permanent link to the image.

Do you have this ?