Error CoArchi on Publish changes

Started by asc, March 24, 2022, 11:15:22 AM

Previous topic - Next topic

asc

Hello,

I have an error when I want to publish changes from Archi with ArchiCo plugin to a GIT on Azure DevOps :
"There is an error : https://..... : not authorized" (screenshot in attachment)

But when I try to commit with GIT in command line (git push origin branch_name), that's work.

Is someone have an idea why it doesn't work in ARchi ?

Archi Version 4.9.2
Plugin CoArch 0.8.2 (in screenshot)

error_archi (2).png
version_plugin (2).png

anderstn

I am having the same issue. The only difference being that we locally use HTTP and not HTTPS for our repository (PS: I would never use HTTP for this even if the traffic is local, but I'm not in charge of the department that owns this so there is little I can do about it).

xiaoqi

Hello asc,

Our team are also putting Archi model repo in Azure DevOps, I saw this kind of issue sometimes, it can happen in variable Archi version, so from my experience, it's not relating to Archi Main Tool or coArchi plug-in.

Could you verify two possible problem areas?

1) Whether your personal token generated from Azure DevOps site has been expired? If you didn't specify, it can only a short period and can be overdue soon. Or

2) Check on the "Authentication" tab of your model within Workspace is keyed in correct User Name, which should be same from Azure DevOps when you trying to do "clone"

Good luck.

Martine

Hello,
I'm having the same problem, @asc did you manage to find a solution ?
@xiaoqi, I'm totaly new with Github I only use it for Archi, could you help me please ?
It seems your first point is not finished, could you complete your suggestion ?
As far as I can tell, my token is ok (see attachment).
I checked your second point, it's ok.
Thanks for any help.
2022-04-07 19_23_24-Settings · Personal access tokens.png

Martine

Hello,
in case it would help someone, here is what finally worked for me...
First, I had to reset my primary password, see here : https://forum.archimatetool.com/index.php?topic=1200.0
But I'm not sure this has to be done, perhaps something went wrong because of all my tests...

Then, I generated a new password from GitHub (see attachment 1)
Then, put this temporary password in model properties (see attachment 2)
I could then publish again!

Afer closing and reopening Archi, when I published for first time, I was prompted to enter the "real" primary password, the properties where updated with the "real" primary password, and the publish went well.

Hope this helps.
Martine


Martine

#5
Attached filesNot a valid attachment ID.2 - put password in authentification.png 

Phil Beauvoir

Martine, I deleted the first image as it contained private info.
If you value and use Archi please consider making a donation! https://www.archimatetool.com/donate

Martine


xiaoqi

Sorry for late replying, not quite sure whether the root cause is the Primary Password or another Github password (we use Azure DevOps not GitHub), but glad to see you're able to publish model now.

By the way, ensure remembe the Primary Password, everytime after you reboot your PC or reopen the Archi, you need that password for your next first commit.

Good luck.

asc

Hello Martine,

Yes I succeed to manage this issue.

I have generated new Azure Devops HTTPS credentials.
I have deleted the credentials file in .git folder.

And finally I have filled the authentification informations in Archi with my new credentials.